This error typically occurs if your hosting environment is setup using an old version of the PHP framework. Obox themes require PHP5 or newer and MySQL5. If you contact your host, they should be able to assist you in enabling this in your account, or upgrading your server.